Font RS PlugIn and SSRS 2008 R2

Need assistance with programming Font Tools? Post here.

Font RS PlugIn and SSRS 2008 R2

Postby BretBolte on Tue Apr 01, 2014 10:32 am

I am trying to use the Font RS PlugIn with SSRS 2008 R2 and the instructions in the knowledgebase only show how to do it with SQL 2000 and 2005. Those instructions do not apply to SSRS 2008 R2 where installing the DLL into the Deploy Folder for the server. I cannot find the ReportServer\bin folder anywhere on the drive. Does anybody have an idea on how to get this to work for SSRS 2008 R2??
BretBolte
 
Posts: 6
Joined: Tue Apr 01, 2014 10:18 am

Re: Font RS PlugIn and SSRS 2008 R2

Postby glitch on Tue Apr 01, 2014 3:04 pm

The SSRS2008 has the same settings as SSRS2005, which is why we only shows the one of SSRS2005. The deploy folder is under c:\program files\Microsoft SQL Sever\MSSQL.n (the n is the instance number). If you can't find Report Server folder, you likely get to the wrong SQL server instance, or you did not install Report Server.
The information above is provided "AS IS", with no warranties, and confers no rights.
User avatar
glitch
Support Engineer
 
Posts: 174
Joined: Wed May 14, 2008 2:42 pm

Re: Font RS PlugIn and SSRS 2008 R2

Postby BretBolte on Wed Apr 02, 2014 10:44 am

Thanks, I found the folder, the person who installed SSRS got tricky and put it on the D: drive instead of in C: with the rest of the SQL folders (D:\Program Files\Microsoft SQL Server\MSRS10_50.HOP1\Reporting Services\ReportServer\bin). I am able to get the barcodes to show up correctly in the IDE now, but when I deploy my reports all the barcodes show "Error" when I display the human readable or change the font on the field to Arial. It is acting like it cannot find the .dll file. The error shows for remote computers as well as when I try running the reports on the SQL server itself. Is there a step I missed for registering the .dll with the deployed reports other than setting the security in the .config file and copying the .dll to the bin folder?
BretBolte
 
Posts: 6
Joined: Tue Apr 01, 2014 10:18 am

Re: Font RS PlugIn and SSRS 2008 R2

Postby BretBolte on Wed Apr 02, 2014 6:26 pm

I am still stuck on this, no matter what I try i cannot get anything other than "Error" for my barcodes on deployed reports. Barcodes in the preview window of the IDE are showing up correctly.
BretBolte
 
Posts: 6
Joined: Tue Apr 01, 2014 10:18 am

Re: Font RS PlugIn and SSRS 2008 R2

Postby glitch on Thu Apr 03, 2014 4:42 pm

The security policy is unnecessarily tricky; and it does not show errors even you put incorrect info there. Also which barcode are you creating? If the report service is 64-bit you need the 64-bit encoder DLL too.
The information above is provided "AS IS", with no warranties, and confers no rights.
User avatar
glitch
Support Engineer
 
Posts: 174
Joined: Wed May 14, 2008 2:42 pm

Re: Font RS PlugIn and SSRS 2008 R2

Postby BretBolte on Fri Apr 04, 2014 8:49 am

I am using the 128B and C codes on my SSRS reports. I am assuming the report service is 64 bit since the operating system is, but I cannot find anywhere that explicitly says if it is 32 or 64 bit. This server was set up by my customer's IT people before I started on the project. Where can I get a 64-bit encoder dll to try it? Also, if I needed the 64-bit encoder wouldn't it have failed in the IDE as well?
BretBolte
 
Posts: 6
Joined: Tue Apr 01, 2014 10:18 am

Re: Font RS PlugIn and SSRS 2008 R2

Postby BretBolte on Fri Apr 04, 2014 12:04 pm

Ok, I downloaded the C# source code for the plugin and created a new project in .Net 2012 and imported/converted that source code into the project and compiled it three times (any, x86, x64). The any compile worked in the IDE but showed "#Error" on every barcode in the deployed reports. The x86 worked in the IDE but when I attempted to deploy the reports I got an error while loading the code module MoroviaFontRSPlugin, and the deployed report from the any compile still showed "#Error" for every barcode on the reports. The x64 compile did not work in the IDE and I got the same "#Error" on every barcode in the deployed reports. Each time I copied the .dll into the two folders I made sure the IDE was shut down and I restarted the ReportServer service. Any suggestions on what else I can try??
BretBolte
 
Posts: 6
Joined: Tue Apr 01, 2014 10:18 am

Re: Font RS PlugIn and SSRS 2008 R2

Postby glitch on Fri Apr 04, 2014 12:13 pm

I think that you are running 64-bit Report Server. Normally if the SQL Server is installed under c:\program files instead of c:\program files (x86), it is 64-bit.

For 64-bit SQL server, you need to install 64-bit encoder DLL.

Download the 64-bit encoder DLL http://download.morovia.com/free/Fontto ... .1.9.5.msi and install it on the server. It should fix the error.
The information above is provided "AS IS", with no warranties, and confers no rights.
User avatar
glitch
Support Engineer
 
Posts: 174
Joined: Wed May 14, 2008 2:42 pm

Re: Font RS PlugIn and SSRS 2008 R2

Postby BretBolte on Fri Apr 04, 2014 3:04 pm

Success! That fixed the problem. Using the RSPlugin.DLL that was compiled with "any" build and using the x64 version of the FontTools install made it work for both the IDE and the deployed reports. Thanks for all the help!
BretBolte
 
Posts: 6
Joined: Tue Apr 01, 2014 10:18 am


Return to Font Tools API

Who is online

Users browsing this forum: No registered users and 0 guests