All Fields work, except one

Issues related to using our fonts in Crystal Reports

All Fields work, except one

Postby BlindRI on Wed Apr 25, 2018 7:46 pm

Using Crystal Reports ver14 with Epicor Prophet 21 ver12
Editing user form "PRODUCTION_user.rpt"
Adding PDF417 (MRV PDF417 N3) to form

using the following in formula:
StringVar DataToEncode := ToText(Right({LINEXXXDEF.ITEM_DESC}, Len({LINEXXXDEF.ITEM_DESC}) - 12)) + Chr(9) + ToText({LINEXXXDEF.ITEM_ID}) + Chr(9) + ToText({HDRXXXXDEF.PRODUCTION_ORDER_NUMBER}) + Chr(9) + ToText({LINEXXXDEF.QTY_CAN_MAKE});

And it works fine...
until I add {EXDSCXXDEF.EXTENDED_DESCRIPTION}

I have tried trimming the field at beginning and end to see if some oddity is there
I have tried just printing it as text on the form, and it prints data from the field normally
I have tried just it by itself in case the concatenation was too long.
I have tried making it with and without the ToText

Since I am using a demo license (until I get proof of concept), the warning message pops up that I am using a demo license, but no ink appears on the form where I place the barcode anytime I use this single field. Why does this single field abort the creation of the barcode?
BlindRI
 
Posts: 3
Joined: Wed Apr 25, 2018 7:32 pm

Re: All Fields work, except one

Postby glitch on Wed Apr 25, 2018 8:39 pm

Likely the overall text exceeds the encoding capacity.

If you are copying the code from the manual, note the numCols parameter is set to 3.

Code: Select all
NumberVar numRows := 0; 
NumberVar numCols := 3;
NumberVar securityLevel := 9;
NumberVar aspectRatio := 0.0;


This limits the number of columns to 3. Increase its value or set it to 0 (automatic).

For more information about sizing parameters in PDF417, see https://www.morovia.com/manuals/PDF417- ... parameters
The information above is provided "AS IS", with no warranties, and confers no rights.
User avatar
glitch
Support Engineer
 
Posts: 196
Joined: Wed May 14, 2008 2:42 pm

Re: All Fields work, except one

Postby BlindRI on Thu Apr 26, 2018 11:17 am

I gave setting it to zero a try. The result was no barcode on the form.

I think you are on the right track because this field is on the same table as the fields that work is the only field with Column Datatype Char(255). But I attempted previously to use a MID() function to trim out 9 characters which did not yield positive results.

Is there another way to reconfigure the field value to strip current attributes that I could test?
BlindRI
 
Posts: 3
Joined: Wed Apr 25, 2018 7:32 pm

Re: All Fields work, except one

Postby glitch on Thu Apr 26, 2018 12:44 pm

Increase numCols to 4, 5 etc and try again. You should get the barcode.

You can play with the GUI encoder to determine the value of numCols needed.
The information above is provided "AS IS", with no warranties, and confers no rights.
User avatar
glitch
Support Engineer
 
Posts: 196
Joined: Wed May 14, 2008 2:42 pm

Re: All Fields work, except one

Postby BlindRI on Thu Apr 26, 2018 4:05 pm

I gave it a try, gave up after columns := 9

The actual characters in the test order is 30. Shouldn't need more than 3 columns for "SEAL KIT PISTON 4.00 X 1.75 CT".

My next thought was move the data somewhere else, but that didn't work either. I typed the data into another field and had the same issue with it. Why do some fields work and some don't.
BlindRI
 
Posts: 3
Joined: Wed Apr 25, 2018 7:32 pm

Re: All Fields work, except one

Postby glitch on Thu Apr 26, 2018 4:26 pm

Something is wrong here. You should be able to encode 30 characters with numCols := 3.

Now I suspect that you have a very large {EXDSCXXDEF.EXTENDED_DESCRIPTION} field filled with many blanks. Use Len() function to find our the real length, then call trim/replace to remove those blanks.
The information above is provided "AS IS", with no warranties, and confers no rights.
User avatar
glitch
Support Engineer
 
Posts: 196
Joined: Wed May 14, 2008 2:42 pm


Return to Crystal Reports

Who is online

Users browsing this forum: No registered users and 1 guest